How to fix Joomla HTTP 500 errors after updates

Date posted: 2013-11-12
Last updated: 2026-10-03

Here is how to resolve Joomla HTTP 500 errors (0x8007000d) on IIS after applying Joomla updates, by fixing the database from the back-end.

Over the last week, at Vevida, we received quite some problem reports from customers who updated Joomla to version 3.2.0. After logging on to their administrator back-end, they received an HTTP 500.0 error with error code 0x8007000d. Let's investigate and resolve this Joomla Administrator login HTTP 500 error. The information in this post is still valid, even for Joomla 3.6.4 and up!

When Joomla's administrator login ends in an HTTP 500.0 error after an update, browse to administrator/index.php?option=com_installer&view=database and click the Fix button to repair the database schema. On IIS, also check the file permissions on logs/error.php.

I originally wrote this post in 2013 for Joomla 3.2 and updated it for Joomla 3.6. Joomla 3 has reached its end of life; the Database page with its Fix button is still available in the Joomla administrator under System > Maintenance > Database.

What is this Joomla HTTP Error 500?

Unfortunately this Joomla HTTP Error 500: Internal Server Error has nothing important to tell, except in case of IIS as web server:

Internal Server Error, The data is invalid. (0x8007000d)

That's not much... It basically means that somewhere the output breaks FastCGI and PHP output. IIS shows the detailed HTTP Error 500.0 page after logging on, and an IIS Failed Request Tracing report shows the same 0x8007000d error code for the request.

How to fix a Joomla HTTP Error 500 after Joomla updates

Often, you can fix this HTTP error 500 in Joomla pretty easily. If only I had known this earlier, it would have saved me some time 🙂 This post certainly will save you time. Follow the next steps:

  1. When you've tried to log on and the HTTP 500.0 error is displayed, add ?option=com_installer&view=database to the URL in the address bar of your browser. The full URL then becomes http://www.example.com/administrator/index.php?option=com_installer&view=database.
  2. After pressing the ENTER key on your keyboard, you're automatically logged on to your Joomla Administrator back-end, on the database page of the Extension Manager.
  3. You'll probably notice database errors: the database is not up to date. These database errors can be repaired easily using the Fix button. This resolves the log on issue permanently.

Curious to learn how to improve Joomla performance with just 8 simple tips?

HTTP 500 fix tested and verified with Joomla 3.2.4, 3.3.6 and 3.6.4

This fix for HTTP 500 errors when logging in to the Joomla administrator is still valid for Joomla 3.2.4, 3.3.6 and Joomla 3.6.4 updates.

Incorrect permissions on Joomla's log/error.php file

It turns out that, at least on Windows Server IIS, PHP/FastCgiModule might throw an 0x8007000d error if file and directory permissions are improperly configured. You must correct the file permissions as well!

However, after setting the correct file permissions on logs/error.php and logging in, Joomla complained about two database problems:

Database schema version (3.1.1) does not match CMS version (3.3.6-2014-09-30).
Database update version (None) does not match CMS version (3.3.6).

These are database problems shown on the same Database page, so use its Fix button as described above.

This post is part of my IIS administration & hardening guide.

I write these posts in my spare time, based on real problems from my day job as a sysadmin. If this one saved you some debugging time, a small donation is much appreciated. Thanks! 🙏

Leave a Comment